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The objective of this workshop is to introduce you to some techniques for using SPSS as well as other tools to support your data management (RDM) activities during the course of your research. It is not about doing statistical analysis using SPSS, but rather how to transform your data, and document your data management activities, in the context of using SPSS for your analyses.

[Michael] Cavaretta said: “We really need better tools so we can spend less time on data wrangling and get to the sexy stuff.” Data wrangling is cleaning data, connecting tools and getting data into a usable format; the sexy stuff is predictive analysis and modeling. Considering that the first is sometimes referred to as "janitor work," you can guess which one is a bit more enjoyable. 
In CrowdFlower's recent survey, we found that data scientists spent a solid 80% of their time wrangling data. Given how expensive of [sic] a resource data scientists are, it’s surprising there are not more companies in this space. 
Source: Biewald, Lukas Opinion: The data science ecosystem part 2: Data wrangling. Computerworld Apr 1, 2015

http://www.computerworld.com/article/2902920/the-data-science-ecosystem-part-2-data-wrangling.html
1. When embarking on the exploration of a new research question, after the literature review, and the formulation of preliminary hypotheses, the next task is generally to begin to identify (a) what variables you need in order to test your hypotheses, and run your models (b) what datafiles (if any) are already available that contain those variables, or whether and how to collect new data, and (c) what software package(s) has the statistical analysis routines and related capabilities (data cleaning, data transformations, etc) that you require.
2. The questions you need to be able to answer, vis-à-vis any software you decide to use, are (a) does the software support the statistical analyses that are most appropriate for my research question and data? (b) how good/defensible are the measures that the software will produce? (c) will it support the data exploration and data cleaning/transformations I need to perform? (d) how will I get my data into the software (ie what file formats can it read)?, and (e) equally importantly, how can I get my data out of that software (along with any transformations, computations etc) so that I can read it into other software for other analyses, or store it in a software-neutral format for the longer term? This workshop assumes you have decided to use SPSS for your data cleaning and analyses, at least in part.  This document, and the exercises, are based on SPSS versions 21/22 for Windows.
3. Advantages to SPSS include: 
· flexible input capabilities, (eg hierarchical data formats)
· flexible output capabilities 
· metadata management capabilities, such as variable and value labels, missing values etc
· data recoding and computing capabilities
· intuitive command names (for the most part)
· statistical measures comparable to those from SAS. Stata, etc.
· good documentation and user support groups (see Appendix A)
Disadvantages to SPSS include: 

· doesn’t do all possible statistical procedures, but then, no statistical package does
· does not handle long question text well
· allows very long variable names (>32 characters) which cannot be read by other statistical packages
· default storage formats for data and output log files are software-dependant (but this is also true for most statistical packages)
4. The data being used in this exercise are a subset of variables and cases from:

Sandercock, Peter; Niewada, Maciej; Czlonkowska, Anna. (2014). International Stroke Trial database (version 2), [Dataset]. University of Edinburgh, Department of Clinical Neurosciences. http://dx.doi.org/10.7488/ds/104.
The citation specifies that this is ‘version 2’. An important part of data management is keeping track of dataset versions and documenting the changes that have happened between versions, especially of your own data.  The web page describing the data set has that information.
You should have access to the following files:

· ist_corrected_uk1.csv – a comma-delimited file, which we will convert to an SPSS system file

· ist_corrected_uk2.sav – an SPSS system file from which we will add variables 
· ist_corrected_eu15.sav – an SPSS system file from which we will add cases 
· ist_labels1.sps – an SPSS syntax file to add variable-level metadata to the SPSS file

· IST_logfile.xlsx – a sample log file in Excel format

Data log file
5. As part of managing your data it is important to create your own documentation as you work through your analyses.  It is good practice to set up a Data log right at the start of a project, to keep track of eg the locations of versions of datafiles and documentation, notes about variables and values, and file and variable transformations, output log files, etc.  This is information that is easily forgotten, within days, much less months, and should you make a mistake, will help you backtrack to a good version of your dataset.
The Data log file will also help you, at the end of your project, to identify what versions of the data file(s), syntax files, and output files to keep, and which can be discarded. At a minimum, you should keep the original and the final versions of the datafile(s), as well as the syntax files or output files which include the syntax, for all transformations, as well, of course, as keeping the data log file. Keeping these files, will assist you to defend your transformations and analyses, should they be queried in the future.

6. The software you choose in which to manage your data log is a matter of personal choice. Some researchers prefer to use a word processor (eg MS Word), others to use a format-neutral text editor, such as Notepad or EditPad Lite, and yet others prefer the table handling and sorting capability of Microsoft Excel (see the file ‘IST_logfile.xlsx). The following are suggested fields for the Data log file:
· Date (YYYYMMDD)
· The input file location and format (‘format’ is especially important if you are working in a MacOS environment, which does not require format based filename extensions). The first entry should be where you obtained the data [if doing secondary analysis]
· The output file location,  name and format

· A comment as to what was done between input and output.

· If using Excel, rename the sheet, eg ‘data log’ – we will be adding more information later
· Before you do anything else, save the Data log file (assign a location and name that you will remember), but leave it open.
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process
sorted on CNTRYNUM (n=19,435, vars=112)

subset (CNTRYNUM=27), n=6,257 vars=112

subset (any(CNTRYNUM,2,3,8,9,10,11,14,15,19,22,24,31)), n=6,561 vars=112

added respno variable, subset (CNTRYNUM=27), n=5,257 vars=113

‘added respno variable, subset (any(CNTRYNUM,2,3,8,9,10,11,14,15,19,22,24,31)), n=6,561 vars=113
all vars except followup (FDEAD to FOAC, FU2_DONE) n=5,257 vars=102

followup VARS (FDEAD to FOAC, FU2_DONE, respno) n=5,257 vars=12





Hint: in order to get the correct path and filename of a file in a Windows environment, locate the file in Windows Explorer, and.
Alternative 1: Click in the address bar showing the path at the top of the Windows Explorer window. The display will toggle between read-friendly display, and the full path display. Copy and paste the full path display, and type the filename, or 
Alternative 2: Click on the file to select it. Then right-click, and select ‘Properties’. The exact path will be displayed in the ‘Location’ field of the properties window, and the filename in the first dialogue box. Both path and filename can be copied and pasted into the data log.
7. It is good practice to assume that you may not always be using SPSS, or the same version of SPSS, for your analyses. You may need to migrate data from/to different computing environments (Windows, Mac, Linux/Unix) and/or different statistical software, because no statistical package supports all types of analysis (SAS, Stata, R, etc). Therefore you also need to be aware of constraints on lengths of file names, variable names, and other metadata such as variable labels, value labels, and missing values codes in different operating systems and software packages, some of which are listed in Appendix B.
8. Note: Especially if you are in the habit of working in different computer environments, it is not recommended that you use blanks in file or directory/folder names. Different operating systems treat embedded blanks differently. Instead, use eg underscores or CamelCase to separate words to make names more readable. Ie, not ‘variable list.xls’ but ‘variable_list.xls’ or ‘VariableList.xls’.
Running SPSS and configuring options
9. Open SPSS through your programs menu: Start > IBM SPSS Statistics [nn].  If a dialog box appears asking you whether you wish to open an existing data source, click ‘Cancel’. When you run SPSS in Windows, one window is opened automatically:
– a Data editor window - empty until you open a data file or begin to enter variable values, after which it will have two views, a Variable View and a Data View, 
Once you have loaded a data file, or issued a command from the drop-down menus, a second window will open:

– an Output window, to which output from your commands and error messages will be written.
Additional windows which can be opened from File > New
 or File > Open (if they 

already exist) are:

· a Syntax window, in which you can enter syntax directly,  or ‘paste’ syntax from the drop-down menu choices, edit and run syntax,
· a Script window, in which you can enter, and edit, Python scripts.
Three additional windows, in addition to dialogue windows etc., may or may not open depending on the procedures you are running: (a) a Pivot table editor window, (b) a Chart editor window, and (c) a Text output editor window.
10. Before starting to read data, you should make some changes to the SPSS environment defaults. Select Edit > Options. The Options box has several tabs.  
11. Select the General tab and make sure that, under ‘Variable Lists’, ‘Display names’ and ‘File’ are selected.  This will ensure that the variables in the dataset are displayed by variable name rather than by variable label and that variables are listed in the same order as they occur in the dataset – knowing this order is essential when referring to individual variables or ranges of variables, eg in recode and/or compute commands.  
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12. It is also useful, especially for checking and recoding purposes, to see variable names and values in the output.  By default SPSS shows only labels, not variable names or value codes.  Click on the ‘Output’ tab, and under both ‘Outline Labeling’ and ‘Pivot Table Labeling’, select the options to show: 
· Variables in item labels shown as: ‘Names and Labels’, 
· Variable values in item labels shown as: ‘Values and Labels’.
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11. Itis also useful to see the variable names and values in any output. By default SPSS only shows
the labels, not the names or codes. Click on the ‘Output Labels’ tab, and under both ‘Outline
Labeling’ and ‘Pivot Table Labeling’, select the options to show:

© Variables in item labels shown as: ‘Names and Labels’,

o Variable values in item labels shown as: ‘Values and Labels'.

|

sPsssystemile

Note: PSS can read (and write) a variety of formats. See Appendix D for a detailed list of
software dependant formats and the commands to read and write them. SPSS can also read
more complex file formats, such as multiple records per case, mixed files, and hierarchical files.

. First lets look at one type of external, raw data file. Run Notepad (start > All programs >
Accessories > Notepad) and open the file ‘scotmp_raw.txt’.
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13. Finally, select the ‘Viewer’ tab and ensure that the ‘Display commands in the log’ checkbox (bottom left of the screen) is checked. This causes the SPSS syntax for any procedures you run to be written to your output file along with results of the procedure. This is useful for checking for errors, as well as as a reminder of the details of recodes and other variable transformations, etc. Click ‘OK’ to save the changes.
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Examine the data file
14. First we will look at one common type of external, raw data file, in this case a comma-delimited file, with extension ‘.csv’. Run Notepad++ and open the file ‘ist_corrected_uk1.csv’ (located in Libraries > Documents > SPSS Files).  
Jakobsen's Law. “If Excel can misinterpret your data, it will. And usually in the worst possible way”.

<http://asiapacificparllibs.org/wp-content/uploads/sites/2/2015/12/Australia-Sam-Spencer-Parliamentary-Data-Management.pdf>
Note: Do not use Excel to open the file. Notepad++ (or Notepad) will display the file in a format-neutral way, in a non-proportional font, so that we can see what the file really contains, rather than what Excel interprets the content to be.
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In this data file, each row or unit of observation represents a stroke patient in the IST sample:  patients with suspected acute ischaemic stroke entering participating hospitals in the early 1990s, randomised within 48 hours of symptom onset. The variables in the rows describe characteristics of the patients, their symptoms, treatment, and outcomes. This particular subset contains patients from the UK only, and only those variables describing the patient at the time of enrollment in the trial, and at the 14 day follow-up.

This a simple flat .csv file, with one unit of observation (case) in each row, and the variables relating to that case, in the same order, making up the row, separated by commas. Using the cursor to move around the file, determine:
How many cases (rows) are there in this dataset? (Hint: scroll down and click on the last row. The number of the row is given by Ln in the bottom ribbon of the screen)

Is there a row of variable names as the first row? Y|N
Are there blanks in the data, between commas (the delimiters)? Y|N
Are there blanks embedded among other characters in individual fields? Y|N
Are comment fields and/or other alphabetic variables enclosed in quotation marks? Y|N
Are full stops or commas used to indicate the position of the decimal in real numbers?

NB: SPSS requires that all decimal places be indicated by full stops.

In SPSS, variables must be assigned a variable name, which must follow certain rules (see below). Each variable may optionally also have a variable label which provides a fuller description of the content of the variable. The variable label is free text, up to 256 characters long, and is often used to give eg the text of a survey question. 


Variable name: likeCameron

Variable label: How much do you like or dislike David Cameron

Rules for variable names in SPSS: (a) variable names must be unique in the data set, (b) must start with a letter, (c) be short, about 8 characters is best (d) must not contain spaces but may contain a few special characters such as full stop, underscore, and the characters $, #, and @, (e) should not end with a full stop, and (f) should reflect the content of the variable. Variable names beginning with a ‘$’ (eg. $CASEID, $CASENUM, $DATE, $SYSMIS, etc) are system variables – do not use these as regular variable names. Also, do not use names of SPSS commands as variable names.
Not variable names:

· Patient #

· # chemo cycle

· 7. On a scale of 1 to 5, where 1 is ‘disagree’ and 5 is ‘agree’, please tell us … [etc]
Good variable names:

· Patient# or Patient_no

· chemo_cycle# or ChemoCycleNo

· q7, or agree7, or disagree7
Creating an SPSS system file

15. In common with most statistical packages, SPSS needs a variety of information in order to read a raw numeric data file: (a) the data, and (b) instructions as to how to read the data. In its simplest form, SPSS reads a raw data file (eg ‘ist_corrected_uk1.csv’), a syntax file (eg ‘ist_labels1.sps’), and using the input instructions in the data and syntax files, converts data and metadata into its preferred format, a system file (extension ‘.sav’), which exists only during your current SPSS session unless you save it.
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16. From the SPSS drop-down menus, select File > Read Text Data. In the Open Data window, browse Libraries > Documents > SPSS files to locate and open the ‘ist_corrected_uk1.csv’ file, and finally click on ‘Open’. (This will not work if the file is already open in Excel.)
This will launch the SPSS Text Import Wizard, a 6-step sequence that will request instructions from you as to how to read the .csv file. Remember the answers you gave to the questions in paragraph 13, above, as you work through the steps, particularly in step 2 (yes, you have a row of headers) and step 4 (no, a Space is NOT a field delimiter in this file, only the comma is, and no, there is no ‘text qualifier’).

SPSS will use your input as well as the data in the first 200 cases to automatically compile a format specification for the file. NB if any variable field is longer in later cases than in any instance in the first 200 cases, the content of the longer fields will be truncated.

17. You should, at the end of the Import Wizard process, have 3 SPSS windows: 

A Data Editor : Data View window which contains a spreadsheet-like display of the data: 
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A Data Editor : Variable View window contains a list of variable names and their associated characteristics :

[image: image7.png]Name Type Decimals Label Values Missing Align Measure Role
1 |HOSPNUM Numeic 2 0 None None i Right & Scale  Input
2 RDELAY  Numeic 2 0 None None i Right & Scale  Input
3 |RCONSC Sting 1 0 None None 1 Left & Nominal | Input
4 |sex Stiing 1 0 None None 1 Left & Nominal | Input
5 AGE Numeric 2 0 None. None. 8 Right & Scale N Input
6 RSLEEP  Sting 1 0 None None 1 Left & Nominal | Input
7 RATRAL  Numeic 1 0 None None i Right & Nominal | Input
8 |ReT Stiing 1 0 None None 1 Left & Nominal | Input
9 RVISNF  Sting 1 0 None None 1 Left & Nominal | Input
0 |RHEP24  Numeic 1 0 None None i Right & Nominal | Input
11 |RASP3 Numeic 1 0 None None i Right & Nominal | Input
12 |RSBP Numeic 3 0 None None i Right & Scale  Input
13| RDEF1 Stiing 1 0 None None 1 Left & Nominal | Input
14 |RDEF2 Stiing 1 0 None None 1 Left & Nominal | Input
15 |RDEF3 Stiing 1 0 None None 1 Left & Nominal | Input
16 |RDEF4 Stiing 1 0 None None 1 Left & Nominal | Input
17__|RDEFS Stiing 1 0 None None 1 Left & Nominal | Input
18| RDEF6 Stiing 1 0 None None 1 Left & Nominal | Input
19 |RDEFT Stiing 1 0 None None 1 Left & Nominal | Input
20 |RDEFS Stiing 1 0 None None 1 Left & Nominal | Input
21 STYPE Stiing 4 0 None None 4 Left & Nominal | Input
22 |RDATE String 6 0 None None 6 Left & MNominal ™ Input





An Ouput window listing the syntax SPSS used to read the input data file:
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18. SPSS can read (and write) a variety of formats. See Appendix D for a list of software dependant formats and the SPSS commands to read and write them. SPSS can also read more complex file formats, such as multiple records per case, mixed files, hierarchical files, etc.
A full SPSS syntax file to read a raw data files contains instructions to SPSS re (a) what file to read (FILE=”…”) and (b) how to read it (TYPE=TXT), as well as (c) a data list statement listing the variables, their locations and formats (VARIABLES=…), (c) variable labels statements, (e) value labels statements, and (f) missing data statements. Thus far, we have only provided information for (a) through (c), and later will add (d) through (f).
Data list statement for a fixed field format file:
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Data list statement for a delimited file with one case per row, and no column headers:
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Checking and saving the output 

19. Checking: (1) check the Output window for Error messages, (2) click on the Data Editor window, and check both the Variable View, and the Data View, for anything that looks not quite right. If there are errors, try to figure out what they are. Normally, fix the first error first, and then rerun the job – errors often have a cascading effect, and fixing the first can eliminate later errors. 
Scroll through the Data View window, up, down and sideways, to CHECK that each variable contains the same type of coding, eg there are no words in a column with numeric codes, etc. 
How many cases have been read? Is this the same as the number of rows in the raw data?
Are there the same number of variable names and columns of data? (SPSS assigns default names ‘VAR[nnn]’ to unnamed variables.)
Does each column appear to contain the same type and coding range of data?

Have variables containing embedded blanks, eg comment fields, been read correctly?

Do any variables (eg comment fields) appear to have been truncated?

Have numbers containing decimals been read correctly?
20. Saving the work so far

a. Save the SPSS system file. Select File > Save as and save the file with format ‘SPSS Statistics (*.sav)’. One method to distinguish among versions of a file is to begin each filename with the YYYYMMDD of the date on which it was created, eg: 

i. 20140921ist_corrected_uk1.sav
b. Save the Output file In current versions of SPSS, the Output Viewer is labelled ‘Output[n] [Document[n]] IBM SPSS Statistics Viewer’). It is the window in which output from your procedures is displayed, as well as the syntax that generated it (as a result of the options chosen in paragraph 13 above).  The Output window should now contain the syntax SPSS used to read the .csv file. For data management purposes, this Output file is important documentation and your record of what you have done to the file/variables and what the results were. Therefore, it is very important to keep these output files.  
This output file can be saved. By default the output file is saved as an SPSS-dependant format with default filename ‘Output[n]’, and the extension .spv (.spo in versions prior to SPSS18) which can only be read by SPSS; therefore, instead of saving it, use File > Export to convert it to a .txt, .html or .pdf format (which you will be able to read with other software), with a meaningful filename. And, of course, add this information to the Data log file.
c. Save the syntax file (if you created one): File > Save as. Note that an SPSS syntax file takes the default extension ‘.sps’, and is a flat text file, so readable by any text software.
d. Update the Data log file (Excel) with the names and locations of these files.
Using syntax 
21. You can carry out most of your data analyses and variable transformations (including creating new variables) in SPSS using drop-down menus. Alternatively, you can also analyse and manipulate your data using SPSS command language (syntax), which you can save and edit in a ‘syntax file’, rather than using drop-down menus. For some procedures, syntax is actually easier and more customiseable than using the menus.

22. You need syntax files when:
· You want to have the option of correcting some details in your analysis path while keeping the rest unchanged, 
· You want to repeat the analyses on different variables or data files
·  Some operations are best automated in programming constructs, such as IFs or DO LOOPs 
·  You want a detailed log of all your analysis steps, including comments (and didn’t configure SPSS as above)
·  You need procedures or options which are available only with syntax 
·  You want to save custom data transformations to use it them later in other analyses 
·  You want to integrate your analysis in some external application which uses the power of SPSS for data processing
Source: Raynald’s SPSS tools <http://spsstools.net/en/syntax/>

23.  For example, if you discover that SPSS has truncated some data fields when reading in the .csv file, you can save the syntax to read the data file to a syntax file, edit it to increase the size of individual fields, and rerun it:

· Double R-click in the Output window in the area of the syntax written by SPSS

· Ctrl-C to save the content of the yellow-bounded box around the output

· Menus: File > New > Syntax to open a new syntax file
· Ctrl-V to copy the content of the yellow-bounded box from the Output to the Syntax window

· Edit the syntax file to keep only the syntax text and run it.
The variable ‘DSIDEX’ in this data file is defined, based on the first 200 cases, as a 26 character string variable (A26). To increase the size of that variable to 50 characters, edit the syntax file to read ‘DSIDEX A50’. Then rerun the syntax to read in the raw data file again: click and drag to select the syntax file contents, from the DATA statement down to and including the full stop ‘.’ at the end of the file, or select Edit > Select All, and click on the large green arrowhead (the ‘Run’ icon) on the SPSS tool bar to run it. Then of course, you will need to check the new file as discussed above.

24. Advantages to using syntax:
· a handful of SPSS commands/subcommands are available via syntax but not via the drop-down menus, such as temporary, missing=include and manova
· for some procedures, syntax is actually easier and more flexible than using the menus.
· you can perform with one click all the variable recoding/checking and labelling assignments necessary for a variable
· you can run the same set of syntax (cut and paste or edit) with different variables merely by changing the variable names, and run or re-run it by highlighting just those commands you want to run, and then clicking on the Run icon. 

· annotate the syntax file with COMMENTS as a reminder of what each set of commands does for future reference. COMMENTS will be included in your output files.
 In the exercises that follow you will be using a mix of drop-down menus and syntax to work with the dataset and to create new variables.  

25. Rules to remember about SPSS syntax:

· commands must start on a new line, but may start in any column (older versions: column ‘1’)
· commands must end with a full stop (‘.’)
· commands are not case sensitive. Ie ‘FREQS’ is the same as ‘freqs’
· each line of command syntax should be less than 256 characters in length
· subcommands usually start with a forward slash (‘/’)
· add comments to syntax (preceded by asterisk ‘*’ or ‘COMMENT’, and ending with a full stop) before or after commands, but not in the middle of commands and their subcommands.
· many commands may be truncated (to 3-4 letters), but variable names must be spelled out in full
26. Where do syntax files for reading in the data come from?
a. If you have collected your own data:
· You should write your own syntax file as you plan, collect and code the data.
· Some sites, such as the Bristol Online Surveys (BOS) site, will provide documentation as to what the questions and responses in your survey were, but you will have to reformat that information to SPSS specifications.
· If you are doing secondary analysis, ie using data from another source:
· data from a data archive, should also be accompanied by a syntax file or be a system file which includes the relevant metadata 
· If the data are from somewhere else, eg on the WWW, look to see if a syntax file is provided. If there is a SAS or Stata syntax file, it can be edited to SPSS specs.
· Failing a syntax file, look for some other type of document that explains what is in each variable and how it is coded. You will then need to write your own syntax file.
· And failing that, you should think twice about using the data, if you have no documentation as to how it was collected, coded, and what variables it contains, and how they are coded.
27. To generate syntax from SPSS:
a. If unsure about how to write a particular set of syntax, try to find the procedure in the drop-down menus
b. Many procedures have a ‘Paste‘ button beside the ‘OK’ button
c. Clicking on the ‘Paste’ button will cause the syntax for the current procedure to be written to the current syntax file, if you have one already open; If you do not have a syntax file open, SPSS will create one
d. Note: if you use the ‘Paste’ button, the procedure will not actually be run until you select the syntax (click-and-drag) and click the ‘Run’ button on the SPSS tool bar
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Adding variable and value labels, and user-defined missing data codes
28. Common metadata management tasks in SPSS:
a. Rename variables
b. Add variable labels
c. Optimize variable labels for output
d. Add value labels to coded values, eg ‘1’ and ‘2’ for ‘male’ and ‘female’
e. Optimize length and clarity of value labels for output
f. Add missing data specifications, to avoid the inclusion of missing cases in your analyses
g. Change size (width), write and/or print formats, and # of decimals (if applicable)
h. Change variable measure type: nominal, ordinal, or scale
29. There are a number of additional types of metadata that can be added to an SPSS system file, to make output from your analyses easier to read and interpret. A syntax file to read in a raw dataset normally consists of the following basic parts: 
· Data list: the data list statement begins with an indication of the type of raw file (.csv, .tab. fixed-field; flat, mixed or hierarchical; see appendix D), as well as the input data file path and filename. When reading in the data using drop-down menus (as we have done), SPSS takes this information from the Text import wizard, launched via File > Read text data. 

· Data list subcommand: Variable names, locations, and formats. SPSS takes the information about variable names, [relative] locations, and formats, from input to the Text import wizard, the first row of the data file (if it contains variable names), and the  first 200 lines of a .csv, .tab, or blank delimited input file. If the file is a fixed-field format file, or a delimited file with no column headers (but delimited by eg tabs, commas, or blanks), a Data list subcommand listing variable names, column locations (for fixed-field files), and formats is essential.

· Variable labels: explanatory labels for each variable, eg is ‘weight’ a sample weight, or the weight of the respondent in kilograms/pounds/stone? Variable labels should be succinct enough to allow one to quickly decide, from the first 20-40 characters, which variable(s) to select. This is not the place for full question text – ie don’t have 5 variables in a row that start “On a scale of 1 to 5….”, eg
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Instead, a shorter variable label, omitting all extraneous words, such as ‘Attended: creating a DMP’ is more efficient and informative. 

· Value labels associate for any one variable, an explanatory label which assigns an encoded characteristic to that value. E.g. 1 ‘disagree’ 5 ‘agree’, or 1 ‘female’ 2 ‘male’,  ‘D’ ‘drowsy’, ‘F’ ‘ fully alert’. ‘U’ ‘unconscious’, or 1 ‘female’ 2 ‘male’. 
· Missing data: assigns certain variable values as user-defined missing (as opposed to system-missing, ie blank fields, unreadable codes, etc), which affects how variables are used in statistical analyses, data transformations, and case selection. More about missing values in paragraph 31.
These additional characteristics can be entered, for each variable, directly into the Data Editor : Variable View window, although this can become quite tedious, depending on how many variables are in the data set. Alternatively, you can use a syntax file to batch-add this information. An SPSS syntax file(s) containing the commands to read a data file into SPSS may accompany the data obtained from a secondary source (such as a data archive/data library) or you may need to create it using the information included in codebooks, questionnaires, and other documentation describing the data file.
30. In SPSS, use File > Open > Syntax, and browse to locate and open the syntax file ist_labels1.sps’. 
Click and drag to select the syntax file contents, down to and including the full stop ‘.’ at the end of the file, or select Edit > Select All, and click on the large green arrowhead (the ‘Run’ icon) on the SPSS tool bar to run it. 
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Content of IST_labels.sps
The variable labels section:
[image: image15.png]variable labels
HOSENUM 'Randomisation: Hospital mumber’

RDSIAY 'Randomisation: Delay between stroke and randemisation in hours’
RCONSC *Randomisstion: Conscious state st randomisstion’

S5X 'Randomizstion: Sex'

6% "Randomisation: Age in years'

RSLEZP 'Randomisation: Symptoms moved on waking'

RATRIAL 'Randomisstion: Atrial fibrillstion - mot coded for pilet phase
RCT 'Randomisstion: CT befors randomizstion’

RVISINE 'Randomisstion: Infaret visible on CT *

RHEP24 *Randomisation: Heparin within 24 hours prior to randomisation®

(384 paviencs)




The value labels section, for string (alphabetic) variables:
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and more value labels, eg for numeric variables…
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The missing values section:
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31. There are two types of missing values:

a. System missing – blanks instead of a value, ie no value at all for one or more cases (name=SYSMIS)
i. Note: $SYSMIS is a system variable, as in IF (v1 < 2) v1 = $SYSMIS.
while SYSMIS is a keyword, as in RECODE v1 (SYSMIS = 99).
b. User-defined missing – values that should not be included in analyses, eg “Don’t know”, “No response”, “Not asked”. These are often coded as ‘7, 8, 9’ or ‘97, 98, 99’ or ‘-1, -2, -3’, or even ‘DK’ and ‘NA’
c. User-defined missing can be recoded into system missing, and vice versa:
i. Recode to system missing: 
RECODE rdef1 to rdef8  (‘Y’=1)(‘N’=0)(‘C’=sysmis) INTO rdef1_r  rdef2_r rdef3_r rdef4_r rdef5_r rdef6_r rdef7_r  rdef8_r.

EXECUTE.

ii. Recode system missing to user-defined missing: 
RECODE fdeadc (sysmis=9)(else=copy) INTO fdeadc_r.

EXECUTE.
· See additional information about missing values in paragraphs 49-52 and 55.

Checking, displaying and saving dataset information
32. To check the syntax run, and list the variables in their file order, click the ‘Data editor : Variable View’ tab and scroll up and down the list to check for errors, variables without labels, etc.  
It is also advisable to copy a variable list to the Data log file. 
Why should you do this?

a. So that you have a record of what variables and values were in the original data file, before you began recoding, computing and transforming the data
b. Provides a convenient template for documenting variable transformations such as recodes, and new computed variables

c. Provides a convenient template for documenting missing data assignments, etc

33. Select File > Display Data File Information > Working File. 
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In the Output Viewer table of contents you will see that this procedure has produced two tables, one labelled Variable Information, containing a list of variables in the datafile, and the other labelled Variable Values, containing a list of the defined values and their respective value labels.  You will also see the command DISPLAY DICTIONARY in the Output Viewer. You could have produced the same tables by typing that command into the syntax file and running it.
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34. Click on the ‘Variable Information’ table in the Output table of contents, R-click > Copy on the table itself to copy it, then Ctrl+C or Edit > Copy) and paste (Ctrl+V) onto sheet 2 of the Excel Data log file. Rename sheet 2 with the name of the source file and what it contains (eg ‘ist_corrected_uk1 variable list’).  You can then do the same with the table of value labels, copying it to a third worksheet in the Data log file. These Data log sheets function as a handy template for documenting variable and value transformations later. See the relevant sheets in the sample logfile ‘IST_logfile.xlsx’ to see how later variable transformations have been documented.
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Descriptive statistics: checking the variables
35. Why run descriptive statistics?

a. Determine how values are coded and distributed in each variable
b. Identify data entry errors, undocumented codes, string variables that should be converted to numeric variables, etc
c. Determine what other data transformations are needed for analysis, eg recoding variables (such as the order of the values), missing data codes, dummy variables, new variables that need to be computed
d. After any recode/compute procedure, ALWAYS check resulting recoded/computed variable against original using FREQUENCIES and CROSSTABS
36. SPSS can display the number of cases coded to each value of each variable, undocumented codes, missing values, etc. Run these basic procedures to familiarise yourself with a new dataset, new or recoded/computed variables, and to check for problems.
37. Nominal, ordinal (aka categorical) and scale variables (numeric or string): in the Data Editor (either Variable View or Data View) window, click on a variable name (to select it), then R-click > Descriptive statistics. This will produce, in your output window, frequencies for each numeric variable, showing up to 50 discrete values. For variables with more than 50 values, SPSS will report mean, median, standard deviation, minimum and maximum values and range.

38.  Alternatively: frequencies for variables (string or numeric, including continuous variables with > 50 values) can be run through the drop-down menus by clicking on Analyse > Descriptive statistics > Frequencies, selecting the variables, moving them into the right part of the screen, and then clicking OK.  In the example below we have chosen rconsc, sex, and occode – of which the first two are string variables and the last is defined as a numeric, nominal variable (according to the Measure column in the Data Editor variable view).
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Notice the difference in variable type icons to the left of each variable name in variable selection menus. SPSS does its best to guess the type of each variable when the data are read in, but the types can also be set/changed in the Data editor > Variable view window (‘Measure’ column): 
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 indicates a string or alphabetic variable, 
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 indicates a nominal variable, 
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 an ordinal variable, and
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 a scale or continuous variable. 
To generate frequencies for these variables using syntax, instead of the drop-down menus, enter the following into the syntax file and run it:

FREQUENCIES VARIABLES=rconsc sex occode.

EXECUTE.

You can see from the first table in the output below that all 3 variables have data for all cases (all 3 have zeros in the ‘Missing’ row of the first table below:
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The second table contains the frequencies, percents, valid percents (not including missing values), and cumulative percents:
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39. Continuous (‘scale’) variables: To generate descriptive statistics for continuous variables (eg AGE), the type of information provided by frequencies is often not informative. We need a different command. Select Analyze > Descriptive Statistics > Descriptives.
Select the scale variables you want to look at in the left window, move them to the right window, and click on the Options button.
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For this exercise, make sure that Mean, Std deviation, Range, Minimum and Maximum are selected, click ‘Continue’, and ‘OK’ when you are returned to the previous dialogue screen.                 
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The equivalent using syntax is:

DESCRIPTIVES VARIABLES=hospnum rdelay age
 / STATISTICS=MEAN STDDEV RANGE MIN MAX.

EXECUTE.

The Output window should now list the scale variables selected, showing their count (‘N’, minimum, maximum, range, mean and standard deviation (spread around the mean), as well as the SPSS commands that generated the output.
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Notice the difference in the statistics provided by the Frequencies versus the Descriptives procedures for the variable AGE.

What is the mean of the AGE variable? Can you get this from Frequencies or Descriptives?

What is the median of the AGE variable? Can you get this from Frequencies or Descriptives?
What is the mode of the AGE variable? Can you get this from Frequencies or Descriptives?
What is the standard deviation of the AGE variable? Can you get this from Frequencies or Descriptives?

40. Explore/Examine is yet another command that will produce univariate descriptive statistics: 

· Menu: Analyse > Descriptive statistics > Explore
· Syntax:

EXAMINE VARIABLES=age.

This command produces the fullest set of univariate descriptive statistics, including EDA
 measures such as Interquartile range, and measures of skewness and kurtosis. It also, by default, produces both stem-and-leaf and box-and-whisker plots.

41. Collecting syntax: In summary, there are four main ways to collect the syntax you need: 

a. From the drop-down menus, written to the Output window and copied to the syntax file
b. Clicking on the ‘Paste’ button of appropriate procedure windows, writes directly to the syntax file
c. Writing it from ‘scratch’ based on the explanations and examples in the appropriate SPSS manual (see Appendix A)

d. From other external sources on the WWW (Google is your friend 8-)
You can build up a set of commands in your syntax file quite quickly, which is useful for initial examination of the data.  You should also add your own notes to the syntax file – anything that you type with an asterisk (*) in front of it will be treated as a comment by SPSS (don’t forget the full stop at the end of every command and comment).  It is good practice to use comments to give each group of commands a header explaining what the syntax is doing, and, if you are working as part of a team with shared files and file space, name of the person who wrote the syntax and the date it was written. If you highlight and run Comments, together with the syntax to which they refer, the comments will also be echoed in your Output Window.
42. Output and syntax files should be saved for future reference and use the data log file to record the name of each, what each contains, and where it is located.  SPSS syntax files are flat text files, with the default extension .sps (see para. 17 for information about the Output file), and so only need to be saved.  As the Data log file grows, you may find it easier to add new information at the top of the table (ie reverse chronological order) rather than the bottom.

You may also find it useful to set up separate sub-folders for your syntax and output files. During your research project you will inevitably accumulate a number of files. Alternatively, collect all syntax files, output files, and revised data files (where applicable) in one subdirectory, to distinguish them from other analyses of other data files. 
43. During the course of your research you will often have to create your own variables, ie derived variables. Using the drop-down menus for this purpose is not recommended, because an essential part of good data management is keeping a detailed record of how new variables were created, and output files with embedded syntax are the best way of doing this.

However, if you find that you still prefer to use drop-down menus, you should make sure to always either paste what you have done into a syntax file and/or save the output file with the applicable commands in it.
Recoding string variables (recode), or creating derived variables
44. Common recoding tasks, ie recoding existing variable(s)
a. Convert string variables to numeric
b. Change order of values of variables (nominal ( ordinal)
c. Change system missing to user-defined missing 
d. Collapse categories
e. Item reversal
f. Replace missing values with eg variable mean
g. Creating dummy variables
45. Recode methods:

a. Dropdown menus
i. Transform > Automatic Recode 
ii. Transform > Recode into Different Variables
iii. Transform > Recode into Same Variable <– NEVER, NEVER, NEVER use this!!
iv. Transform > Create dummy variables
b. SPSS commands (syntax)
i. Automatic recode (AUTORECODE)
ii. Recode (RECODE)
iii. Recode (convert) (RECODE (CONVERT))
46. This data file contains a large number of string (alphabetic) variables, eg variables coded as Y=yes and N=no, etc. The statistical uses of string variables are very limited. In order to make maximum analytical use of string variables, they must be recoded into numeric variables. ALWAYS recode into a new variable, otherwise you will overwrite the existing variable and lose the original values. I like to use the original variable name, with ‘_r’ appended (eg ‘age’ recoded into ‘age_r’) to indicate that the new variable is a recode, and what the source variable was, but this is not the only way to keep track of these parent-child relationships.
 SPSS provides three major ways to recode string variables into numeric variables, or create derived numeric or string variables:

a. Transform > Automatic Recode will recode string (alphabetic) variables to numeric. The individual alphabetic values become numeric values in the alphabetic order (normal or reverse) of the codes. Ie, a Y/N coded variable will be recoded as ‘N’=1 and ‘Y’=2. 
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Select a variable in the left window, move it to the right window using the arrow. Type a new variable name (in the ‘New Name’ box, to recode the source variable into, and click on the ‘Add New Name’ button, to transfer the new name to the top right dialogue box. Then click on ‘OK’.

Alternatively, to recode a large number of string variables in the same way, it is often easier to run syntax:

AUTORECODE VARIABLES=sex rsleep rct rvisinf rdef1 to stype / INTO sex_r rsleep_r rct_r 
  rvisinf_r rdef1_r rdef2_r rdef3_r rdef4_r rdef5_r rdef6_r rdef7_r rdef8_r stype_r 

  / BLANK=MISSING / PRINT.
Note in the above example, that (1) ‘rdef1 to stype’ refers to a sequential order of adjacent variables, and as input need only be defined by the first and last variable name in the range. However, the names for the new recoded variables need to be defined one by one; (2) the explicit assignment of blanks as missing values, and (3) the subcommand ‘print’ instructs SPSS to output a list of the old and new variable and value labels. Look at the output file, and take note of what happened with the values for stype_r.
Advantage of AUTORECODE:  variable and value labels that have already been defined will be carried over from the string to the numeric variable. 
Disadvantages of AUTORECODE:

· Numeric values are assigned in string order (‘nothing before something’). Ie if your values are ‘1 2 3 4 11 12 13 20 21 22 23 30’ new values will be assigned in the order ‘1 11 12 13 2 20 21 22 23 3 30 4’.

· Order may not reflect categories of an ordinal variable. Eg ‘high, medium, low’ will be assigned in the order ‘1=high 2=low 3=medium’ whereas you will likely want the values to be ‘1=low 2=medium 3=high’.
b. Transform > Recode into Different Variables – use when you do not simply want the order of the values to be based on alphabetic order (ascending or descending) but want to control the order of the values, eg to make a variable ordinal rather than merely nominal, so that ‘agree’, ‘neither’, ‘disagree’ with be recoded as 1=disagree, 2=neither, 3=agree.
With this method, you have total control over the order of the output values. However, variable and value labels are NOT transferred to the new variable automatically.
Using menus: On the first screen, define the output variable name and variable label, and click on ‘Change’ and then the ‘Old and New Values’ button:
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On the next screen, define the old and new values, click on the ‘Add’ button to add each pair of values, and click on ‘Continue’ when finished defining old-new value pairs:
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Now go to the Data Editor > Variable view window, and add a variable label and value labels.

Using syntax: The following syntax will accomplish the same as the above. You can add value labels, define missing data codes, and run frequencies and crosstabs of the source and recoded variables for checking purposes, all in one operation, and if you are not satisfied with the results, rerun from the syntax file again after making needed changes:
RECODE rconsc ('F'=1) ('D'=2) ('U'=3) INTO rconsc_r.

VARIABLE LABELS rconsc_r ‘Conscious state at randomisation - recoded'.

VALUE LABELS rconsc_r 1 ‘Fully alert’ 2 ‘Drowsy’ 3 ‘Unconscious’.
EXECUTE.

c. Recode convert: If a variable is defined in SPSS as a string variable because ‘NA’, ‘DK’ or similar have been used as missing data codes, but otherwise consists of numbers that you want to preserve, you can use the ‘CONVERT’ option to the RECODE command: 
*This uses a variable not available in ist_corrected_uk1.sav.

RECODE yra (CONVERT)('DK' = 98)('NA' = 99) INTO yra_r.

EXECUTE.
SPSS will change all string characters ‘1’ to number ‘1’, string character ‘2’ to number ‘2’, string character ‘3’ to number ‘3’, etc., in addition to the changes specified, so that the output ‘varname_r’ is a numeric variable, rather than a string variable. Ie if your values are ‘1 2 3 4 11 12 13 20 21 22 23 30’ the new numbers will sort in the order ‘1 2 3 4 11 12 13 20 21 22 23 30’ (Compare with Automatic recode, above).

d. Collapsing categories: using the drop-down menus, open Transform > Recode into Different Variables, and use the Range options on the Old and New Values screen:
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Doing this with syntax would look like this:

*Recoding individual years of age into age groups.

RECODE age (lo THRU 60=1)(61 THRU 80=2)(81  THRU hi=3)(else=9) INTO agegrp.

e. Item reversal: often a series of related questions (eg Likert scales) will be uniformly coded positive to negative, or low to high. To prevent respondents simply providing the same response to each item in the list (usually without reading the questions), some questions are negatively worded, so that the lowest number means the highest response, etc. Before you run a Cronbach’s alpha or factor analysis on such scale items, it’s generally a good idea to reverse code those items that are negatively worded so that a high value indicates the same type of response on every item. To do this easily, determine (run Frequencies on the variable) what is the highest valid value for a variable that needs to be reverse coded. Then:
*Reverse coding a scale variable – not available in IST_corrected_uk1.sav.

*’sysfeel1’ is original variable; ‘sysfeel1_r’ is the new variable in reverse order’

*Highest valid value for variable ‘sysfeel1’ is ‘7’.

COMPUTE sysfeel1_r=((7 + 1)-sysfeel1).

VARIABLE LABELS sysfeel1_r ‘sysfeel1 recoded – reversed’.

VALUE LABELS sysfeel1_r 1 ‘strongly disagree’ 4 ‘neutral’ 7 ‘strongly agree’.

47. Checking recodes: Regardless of the recode method you choose, you should alway run frequencies (paragraphs 35-40) and crosstabulations on the source variable and the new recoded variable, including missing values, to ensure that  that all values have been captured correctly, and that you are satisfied with the recodes, etc.   
To run crosstabulations using the drop-down menus: select Analyze > Descriptive Statistics > Crosstabs, selecting eg the original variable for the rows and the recoded variable for the columns. Note that new variables are added at the end of a datafile, and therefore are listed at the end of the Variable list.
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To run crosstabulations using syntax: 
FREQUENCIES VARIABLES=sex sex_r.

CROSSTABS   /TABLES=sex BY sex_r.

Either the drop-down menu or the syntax will result in the following crosstabulation: 
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From the above, we can see that all the ‘F’ codes have been recoded as ‘1’s and all 

the former ‘M’ codes have been recoded as ‘2’s.


Using syntax, you can, however, run the recode, assign variable and value labels, and run 


frequency and crosstabulation checks in the same operation, eg:

*Recoding individual years of age into age groups.

RECODE age (lo THRU 60=1)(61 THRU 80=2)(81  THRU hi=3)(else=9) INTO agegrp.

VARIABLE LABEL agegrp 'Age group - recoded from age'.

VALUE LABELS agegrp 1 'low to 60' 2 '61 to 80' 3 '81 to high' 9 'not available' .

MISSING VALUES agegrp (9).

FREQUENCIES  VARIABLES=agegrp.

CROSSTABS / TABLES=age BY agegrp.

If the output variable is a continuous variable with many values, producing frequencies and crosstabulations for all possible values may not be feasible. But you should examine very carefully the correspondence of missing data codes, and other values that have been specifically mentioned in the RECODE statement:
* Frequencies for selected values of a continuous variable, for all values higher than 85 .

TEMPORARY.
SELECT IF (age GE 85).

FREQUENCIES VARIABLES=age agegrp.

CROSSTABS / TABLES=age by agegrp.

Missing data
48. SPSS recognizes two classes of missing data: system-missing and user-defined missing. 
System-missing are blank variable fields, ie cases with no valid code for a variable (eg a blank), are automatically coded as system-missing by SPSS. 
User-defined missing values are valid codes, often with labels such as ‘unknown’, ‘not applicable’, ‘not asked’, etc., but are values that a researcher may want to include in some statistical analyses, but exclude in others. These must be explicitly defined via a missing values statement, or the missing values defined in the ‘Variable View’ of the Data Editor window. 
* Recoding a string variable and defining a user-defined missing value.

RECODE dsch  ('Y'=1)('N'=0)('U'=8) INTO dsch_r.

MISSING VALUES dsch_r (8).

FREQUENCIES VARIABLES=dsch dsch_r.

Missing values (both user-defined and system-missing) are by default included in frequencies (SPSS 21 and later versions), but not in valid or cumulative percentages, nor in descriptive statistics, cross-tabulations, charts or histograms, etc. 
System missing values are identified as ‘Missing System’ in frequencies output. User-defined missing are identified simply as ‘Missing’:
System missing (original variable): 
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User defined missing (recoded variable):
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What codes to use for missing data is a matter of personal preference. Some prefer to consistently reserve the highest numeric codes, eg codes ‘7’, ‘8’, and ‘9’ for various missing data values, such as ‘don’t know’, ‘not applicable’, and ‘not asked’ respectively (or ‘97’, ‘98’, and ‘99’ for 2-digit codes, ‘997’, ‘998’, and ‘999’ etc). Others prefer to use negative values, eg ‘-7’, ‘-8’, and ‘-9’, and some use alphabetic codes ‘DK’ and ‘NA’. 

49. We can explicitly request user-defined missing values (but not system-missing values) be included in crosstabs using syntax: 

RECODE dplace ('A'=1) ('B'=2) ('C'=3) ('D'=4) ('E'=5) ('U'=8) (ELSE=9) INTO dplace_r.

VARIABLE LABELS dplace_r 'Other 14 day event: discharge destination - recoded'.

VALUE LABELS dplace_r 1 ‘home’ 2 ‘relatives home’ 3 ‘residential care’ 4 ‘nursing home’ 

  5 ‘other hospital departments’ 8 'unknown' 9 'not coded'.

MISSING VALUES dplace_r (8,9).

EXECUTE.

FREQUENCIES VARIABLES=dplace dplace_r.

CROSSTABS / tables= dplace_r by dplace / MISSING=INCLUDE.


Which produces the following output:
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50. Now that the data file has been changed, it should be saved with a new file name and recorded in the Data log, eg:  
* Save file as a new version.

SAVE OUTFILE="[path]\[date]ist_corrected_uk1.sav" / MAP / ALL.
It is also important to keep a list of derived variables and the syntax files that created them in your Data log, eg in new columns, identifying the new variable name, values, labels etc.
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 As you work through your analyses you should also add notes to remind yourself if you have to correct any of the derived variables.
Creating new variables (compute)
51. Common compute operations:
a. Create a unique respondent or record identifier
b. Compute eg an index variable from a group of related variables
c. Create a new variable from part of an existing variable
d. Log transformation of a variable
e. Creating a weight variable from existing variables
52. Compute is an important related command that can be used to create a new variable (numeric or string), such as a constant, a sequential case number, a random number, or to initialize a new variable, or used to modify the values of string or numeric variables. It can be run from the drop-down menus Transform > Compute Variable, or via syntax as in the following examples. 

(a) To create a unique identifier variable for each case in a dataset, the syntax is very simple: 

COMPUTE respid=$CASENUM.

FORMAT respid (F8.0).

EXECUTE.

       (b) To compute an index variable as the sum of 8 binary (aka dummy) variables:
RECODE rdef1 to rdef8  (‘Y’=1)(‘N’=0)(‘C’=SYSMIS) INTO rdef1_r  rdef2_r rdef3_r rdef4_r rdef5_r rdef6_r rdef7_r  rdef8_r.

COMPUTE deficits=SUM(rdef1_r,rdef2_r,rdef3_r,rdef4_r,rdef5_r,rdef6_r,rdef7_r,rdef8_r).

FREQUENCIES deficits.
(c) Compute can also be used to create more than one output variable from parts of an existing variable. For example, the variable ‘rdate’ (para. 16) was coded as ‘lut-91’, ‘mar-91’,  ‘sty-91’, etc (ie month (in Polish, abbreviated to 3 characters) plus a 2-character year code. This string variable can be unscrambled into two separate numeric variables ‘rmonth’ and ‘ryear’.

First the month component: 

* Declare a new string variable ‘montha’.

STRING montha (a3).

*Compute the new variable=the 1st 3 characters of the original variable ‘rdate’.

COMPUTE montha=(substr(rdate,1,3)).

* Recode the new variable ‘montha’ into a numeric variable ‘rmonth’ assign labels.

RECODE montha ('sty'=1)('lut'=2)('mar'=3)('kwi'=4)('maj'=5)('cze'=6)

  ('lip'=7)('sie'=8)('wrz'=9)('lis'=11)('gru'=12)(else=10) INTO rmonth.

VARIABLE LABELS rmonth 'Month of randomization - recoded from rdate'.

VALUE LABELS rmonth  1 'January'  2 'February' 3 'March' 4 'April' 5 'May' 6 'June'

  7 'July' 8 'August' 9 'September' 10 'October' 11 'November' 12 'December'.

* Check the new numeric variable.

FREQUENCIES VARIABLES=rdate montha rmonth.
CROSSTABS TABLES=rmonth by montha rdate.
And then the year component:
* Declare a new string variable ‘yra’ 2 characters in width.

STRING yra (a2).

* Compute a new string variable ‘yra’ starting after the dash and 2 characters long.

COMPUTE dash = index(rdate,'-').

COMPUTE yra = substr(rdate,dash+2).

* Recode the new variable ‘yra’ into a numeric variable ‘yr’.

RECODE yra (CONVERT) into yr.

* Compute a new 4-digit numeric variable ‘ryear’.

COMPUTE ryear=(1900+yr).

FORMAT ryear (f4.0).

* Label the new variable, and check the frequencies.

VARIABLE LABELS ryear 'Year of randomization - recoded from rdate'.

FREQUENCIES VARIABLES=yra yr ryear.
CROSSTABS TABLES=ryear by yra yr.
(d) To compute the log of eg a skewed variable, the syntax is: 

COMPUTE ln_y=LN(y).
VARIABLE LABELS ln_y ‘Log of y’.
53. As with recodes, where possible, you should always check the accuracy of the results of compute functions using frequencies and crosstabs, (paragraph 47, above) to compare the results of the compute statement(s) against existing variables, where applicable.
Remember: ‘Frequencies’ lists missing data, both user defined and system missing. ‘Crosstabs’ lists only user-defined missing data categories, if explicitly requested via the ‘/ MISSING=INCLUDE’ subcommand.
54. It is important to update your Data log file with information as to how new variables have been computed, and the new values of recoded variables: 
New variable-level information in Data log file - computed or recoded:
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New value-level information in data log file – computed or recoded:
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Common file transformations:
· Add variables from other dataset(s)
· Add cases from other dataset(s)
· CASESTOVARS and/or VARSTOCASES transformations
Adding variables to a data file
55. If the variables comprising a data file have been split across two (or more) physical files, and those files have a unique case-identifier variable in common, you can use MATCH FILES to add the variables from one data file to the other, so that you can do analyses using variables from both files together. MATCH FILES can match up to 50 files in one operation, as long as:
a. All files are SPSS system files (.sav extensions)
b. All files have the same unique case identifier variable (key variable):
i. Case identifier names must be the same (including same case, ie upper/lower)
ii. Case identifier variables must be the same type (string or numeric)
iii. Case identifier variables must have the same width and number of decimals
c. All files are sorted in the same order by the unique case identifier (Data > Sort Cases)

d. Any duplicate variable names must be renamed or be excluded
As a first step, with ist_corrected_uk1.sav open in SPSS, open the file ist_corrected_uk2.sav (an SPSS system file), which contains additional variables from the 6-month follow-up of the patients in the file you already have open. 
Now that you have 2 data files open in SPSS, you can use the listing under Window in the SPSS tool bar to make each file in turn the ‘Active file’. 
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56. Check the specifications of the key variable ‘respno’: 
Is there a unique identifier for each respondent (eg the ‘respno’ variable) in both files?
Does the identifying variable have the same name in both files? Is it in the same case (upper/lower/CamelCase)? 

Is the variable name the same type (string/numeric) and width in both files?
Are there other variables with the same name in more than one file? Which should you keep? Why? (If you decide to keep both, you must rename one of them.)
You also need to ensure that both files are sorted in the same order by the key variable (‘respno’): use Data > Sort Cases to sort each file. If you decide to save the sorted files (with new filenames, of course). I like to just append ‘_s’ to the original filename when saving a sorted version, to indicate that it is a sorted version.
57. To check whether the respondent identifier variable is unique in each file, select Data > Identify Duplicate Cases from the drop-down menus and run, with the respondent identifier variable as input, for each file (doing this with syntax is much more involved). The following output informs us that all 6,257 cases in the *_uk1.sav data set are primary cases (ie unique), and not duplicate records.
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58. Once you have sorted the files, and checked for unique key variables, the syntax for MATCH FILES is actually quite simple:
*Merging ist_corrected_uk1.sav, and ist_corrected_uk2.sav  on 'respno'.

DATASET CLOSE All.

MATCH FILES FILE= "[path]\ ist_corrected_uk1.sav "

 /FILE="[path]\ist_corrected_uk2.sav "

 /BY respno.

EXECUTE.

SAVE OUTFILE ="M:\[path]\ ist_corrected_uk.sav" /   KEEP=all / MAP.
Alternatively, use the drop-down menus: Data > Merge Files > Add Variables:
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The additional variables will be added to the active dataset, ie ‘ist_corrected_uk1’.

Check ist_corrected_uk1 (the active dataset) to make sure that the variables from *uk2 are indeed listed in the Data View and Variable View windows. 
How many cases are there now in the Ist_corrected_uk1.sav file?

How many variables are there now in the Ist_corrected_uk1.sav file?
Save this version of the dataset with a new name, eg ‘Ist_corrected_uk.sav’, to reflect that it now contains the variables from both input datafiles, and update the Data log file.
Adding cases to a data file
59. Another common file transformation activity is to add cases to an existing data file. In this instance, the ‘ist_corrected_uk.sav’ dataset (which now contains all the variables from ist_corrected_uk1.sav and ist_corrected_uk2.sav) currently contains only UK stroke victims. In order to compare them with cases from other countries in the EU, we need to add additional cases from the trials in the EU countries as well.
With ‘ist_corrected_uk.sav’ open in SPSS as the active file, select Data > Merge files > Add cases. 
You will be prompted for the name of an SPSS system file from which to add cases to the current active file – either one that is already open, or one that has previously been saved as an SPSS system file on your system. In this case you will be adding cases from ‘ist_corrected_eu15.sav’:
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Click on the name of the file you want to add cases from (if you have several files open), and then on ‘Continue’.
60. The next dialogue screen lists, in the right window, all variables held in common between the two files being merged, and in the left window, those that occur in only one or the other file, with an indication as to which file each variable is from – these are primarily the derived variables created with the RECODE command. These unmatched variables can be included in the output data set (move them into the right window), but will be set to system missing for those cases in which the variables do not have valid values. Alternatively, they can be excluded from the new merged file (the default). 
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Variables must match on several aspects in order to be ‘paired’ between the two files: (a) the variable names match is case sensitive, (b) both variables in both files must be the same type (string or numeric); string variables are flagged by ‘>’, (c) variables must have the same width and number of decimals. 
Once you are satisfied with the list of variables to be included in the new dataset, click on the ‘OK’ button. The new cases will be added to the active datafile (‘ist_corrected_uk.sav’). Check the Output file, and the ‘ist_corrected_uk.sav’  file for errors or problems you did not anticipate. 

How many cases are there now in the ‘ist_corrected_uk.sav’ file?

How many variables are there now in the ‘ist_corrected_uk.sav’ file?

61. When SPSS does something unexpected, it is a good idea to paste the syntax into your Syntax file, and check the the syntax against the SPSS manual to see what is happening, in case you missed or misinterpreted some defaults or options. As you can see from the syntax below, SPSS’s default is to first rename all unmatched variables, and then DROP them from the resulting merged file:

*Add EU15 cases.

DATASET ACTIVATE DataSet2.

ADD FILES /FILE=*

  /RENAME (deficits DLACE_recm DPLACE_r DPLACE_recm DPLACE_syn PrimaryLast 
    RCONSC_r rdef1_r rdef2_r  rdef3_r rdef4_r rdef5_r rdef6_r rdef7_r rdef8_r SEX_r=d0 d1 d2 
   d3 d4 d5 d6 d7 d8 d9 d10 d11 d12 d13 d14 d15)

  /FILE='DataSet1'

  /DROP=d0 d1 d2 d3 d4 d5 d6 d7 d8 d9 d10 d11 d12 d13 d14 d15.

EXECUTE.

Try Merge Files > Add Cases again, until you are happy with the result. Save the new file, eg as ‘ist_corrected_merged.sav’ and log it in the Data log file. 
Writing a raw data file

62. As important as reading a data set into SPSS is writing it out in another format, either for use in a different statistical package, for long-term preservation, or both. 
63. Options:

a. Software packages such as StatTransfer convert data files among a wide variety of different software dependant and generic formats (with/without syntax files). The Data Library has StatTransfer and can help with this.
b. Software packages such as SledgeHammer, and Colectica will write a generic format data file (usually .csv) and a DDI-standard .xml metadata file. The Data Library has SledgeHammer, and can help with this also.
c. Many statistical software packages can read in an SPSS system file (*.sav)
d. Use SPSS menus: File > Save as to write tab- or comma-delimited (*.csv), or fixed field ascii formats (in the latter case, ALWAYS use the TABLE subcommand and save the output)
e. Use SPSS syntax to write out one of a number of other software-specific output formats (see Appendix D of the workshop handout) 
f. Note: SPSS no longer writes SPSS syntax files, so if you have used option d, you will need to write a syntax file ‘manually’.  
64. Use the appropriate SPSS command to write the output data file in an appropriate format (see Appendix D for a list of SPSS outfile commands and the formats SPSS can write). 
Generate the variable information (File > Display Data File Information > Working File) for the file you need to save, or run DISPLAY DICTIONARY from the Syntax window. Save the variable and value lists.
The most generic, non-controversial, and least error-prone data format (for reading into other software) is fixed-field format ASCII. This format can handle many file structures, including varieties of hierarchical files, and is not sensitive to commas and/or blanks embedded in variables. A popular format is .csv, which is more error-prone.
You can save a data file as a comma-delimited, tab-delimited or fixed field format file (‘Fixed ASCII’), using File > Save as… from the menu bar, and selecting the appropriate option under ‘Save as type’:
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65. A third alternative is to use syntax to write a fixed field format or a comma-delimited file. The advantage of using syntax is that you can easily switch recoded variables for original variables, and change the order of variables, rather than have all your recoded variables appear at the end of the data file.  You can also use the TABLE option to have SPSS produce a list of the column locations to which variables are being written:
DISPLAY DICTIONARY.

WRITE OUTFILE="[path]\[filename].txt” TABLE / hospnum rdelay rconsc_r sex_r age rsleep ratrial rct 

      to respno.
EXECUTE.

66. If you are writing a fixed-field ASCII data file (ie ‘Fixed ASCII’), make sure to EXPORT the output table which indicates what columns the variables are written to, as well as the file information generated above – this is your only record of what variable is in what column(s), and what the values mean.
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67. Check your output. Open the data file in a format neutral editor, such as Notepad++. Check the column number against the output table generated by SPSS to make sure that the final column numbers and case counts match.
68. Save the raw data file (file extensions such as .txt or .dat), the output file (in a software neutral format), and the file in which you have stored the variable and value lists. And finally, of course, update and save the Data log!

· SPSS data file (Data view/Variable View window)

File > Save as > SPSS system file (.sav extension)

· SPSS Output viewer window

File > Export as > (prefer text, html or PDF formats)
· SPSS syntax file

File > Save as > SPSS syntax file (.sps extension)

· Data log file

File > Save as > (appropriate format and extension)
Wrap-up

If you remember nothing else from this training session:
· You must always be able to backtrack through the versions of the data, therefore:
· NEVER, NEVER, NEVER overwrite an existing variable when recoding or computing. ALWAYS recode or compute to a new variable name. Why? – because you WILL make mistakes.
· ALWAYS, ALWAYS, ALWAYS save each version of the data file under a new name (ie NEVER overwrite the old dataset) after variable and file transformations, eg
· 20160202.mydatafile.sav
· 20160203.mydatafile.sav
Why? – because you will very soon forget what you did to each file, especially if you didn’t use and save the syntax/output file(s). Always keep your Data log file up-to-date – you will be grateful you did, in the long run.
· And, for support, Google is your friend (see also Appendix A in the workshop handout)
And listen to Bart:
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Appendix A: My favourite on-line resources:

IBM SPSS Statistics 22 manuals

http://www-01.ibm.com/support/docview.wss?uid=swg27038407
IBM SPSS Statistics 22 Command Syntax Reference

ftp://public.dhe.ibm.com/software/analytics/spss/documentation/statistics/22.0/en/client/Manuals/IBM_SPSS_Statistics_Command_Syntax_Reference.pdf
Raynald’s SPSS tools: http://www.spsstools.net/
University of California. Institute for Digital Research and Education (IDRE)/Resources to help you learn and use SPSS:  http://www.ats.ucla.edu/stat/spss/
Selecting the right statistical analysis: http://statpages.org/index.html#WhichAnalysis
Appendix B:  Selected inter-system limitations on filenames, variable and value names etc. [at time of writing]
· Path (subdirectory) and file names: different operating systems treat embedded blanks in subdirectory and file names differently. Windows and MacOS allow filenames with embedded blanks, whereas these need to be surrounded by quotes in Unix/Linux operating systems.

· Do not use blanks or most other special characters in subdirectory and/or file names (eg ‘variable list.xlsx’
· Do use: underscores (‘variable_list.xlsx’), or CamelCase (‘VariableList.xlsx’)
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Variable names
· In SPSS variable names must begin with a letter or the characters ‘@’, ‘#’ or ‘$’, and names beginning with ‘#’ or ‘$’ have special functions (scratch and system variables). Variable names should not end in a full stop since this is a command terminator in SPSS.

· SAS variable names must begin with a letter, or an underscore ‘_’. Tab characters embedded in string variables are preserved in tab-delimited export formats. 

· Special characters such as ‘@’, ‘#’ and ‘$’ are not allowed in SAS variable names, the last three are replaced with underscores. In Stata, the only allowable characters are letters, numbers, and underscores.

· Case sensitivity: SAS will convert variable names ‘mpage’ and ‘MPage’ to  ‘MPAGE’ for purposes of analysis (ie treat all 3 versions as one and the same variable), ‘though not for purposes of display. In Stata, however, these are treated as 3 different variables. In SPSS, existing variable names are not case sensitive, while new variable names are.

· Variable names longer than 8 characters are truncated when exported to SPSS versions pre 12.0, SPSS .por files, SAS pre-V7, and Stata versions pre-7.

· Note: it is generally recommended that variable names be no more  than 8 characters

Other restrictions
· When writing files in Stata 5-6 or Intercooled 7-8 formats, only the first 2,047 variables are saved.
· All SPSS user-defined missing values are mapped to a system-missing value in SAS.

· Variable labels longer than 40 bytes are truncated when exported to SAS v6 or earlier.

Appendix C: Common file and variable transformations and their corresponding SPSS commands:
File transformations


SPSS syntax

· Sort cases




SORT CASES

· Sort variables



SORT VARIABLES

· Transpose (cases and variables)

FLIP

· Convert multiple records/case to one 

record per case with multiple variables
CASESTOVARS

· ‘Flip the file’



VARSTOCASES

· Merge – add cases



ADD FILES

· Merge – add variables


MATCH FILES

· Weight cases



WEIGHT

· Split files




SPLIT FILE

· Aggregate data



AGGREGATE

Variable transformations

· Compute new variables


COMPUTE

· Recode




RECODE

· Rank cases




RANK

· Random number generation

Transform > Random Number Generators

· Count occurrences



COUNT

· Shift values




SHIFT VALUES

· Time series operations


CREATE

RMV



SEASON

DATE

SPECTRA
	Appendix D: SPSS read and write commands
	

	SPSS 19 commands to read file
	format
	SPSS 19 commands to write outfile
	Note: "[fn]" = path and filename

	data list file="[fn]" list or data list file="[fn]" free
	comma-delimited file
	save translate / outfile="[fn]" / type=csv
	By default, both commas and blanks are interpreted as delimiters on input.

	get data / type=oledb / file="[fn]"
	database with Microsoft OLEDB technology
	
	

	get data / type=odbc / file="[fn]"
	database with ODBC driver
	save translate / connect=ODBC
	

	get translate / type=dbf / file="[fn]"
	dBASE II files
	save translate / outfile="[fn]" / type=db2 / version=2
	

	get translate / type=dbf / file="[fn]"
	dBASE III files, dBASE III Plus
	save translate / outfile="[fn]" / type=db3
	

	get translate / type=dbf / file="[fn]"
	dBASE IV files
	save translate / outfile="[fn]" / type=db4
	

	get data / type=xls / file="[fn]"
	Excel 2.1 (pre-Excel 95)
	save translate / outfile="[fn]" / type=xls / version=2
	

	get data / type=xlsm / file="[fn]"
	Excel 2007 or later macro-enabled workbook
	
	

	get data / type=xlsx / file = "[fn]"
	Excel 2007 or later workbook
	save translate / outfile="[fn]" / type=xls / version=12
	

	get data / type=xls / file="[fn]"
	Excel 95
	save translate / outfile="[fn]" / type=xls / version=5
	

	get data / type=xls / file="[fn]"
	Excel 97 thru Excel 2003 files
	save translate / outfile="[fn]" / type=xls / version=8
	

	get translate / type=slk / file="[fn]"
	Excel and Multiplan in SYLK format
	save translate / outfile="[fn]" / type=slk
	

	get translate / type=xls / file="[fn]"
	Excel pre-5
	save translate / outfile="[fn]" / type=xls / version=2
	

	get translate / type=wk / file="[fn]"
	Lotus 1-2-3 file, any
	
	

	get translate / type=wks / file="[fn]"
	Lotus 1-2-3 release 1A
	save translate / outfile="[fn.sys]" / type=wks
	

	get translate / type=wk1 / file="[fn]"
	Lotus 1-2-3 release 2.0
	save translate / outfile="[fn.sys]" / type=wk1
	

	file handle [nickname] / mode=multipunch.

data list file=”[nickname]”
	multipunched raw data (aka column binary)
	
	

	data list file="[fn]" fixed
	raw data, inline or external file, fixed format 
	write outfile="[fn]" table. Execute.
	

	data list file="[fn]" list or data list file="[fn]" free
	raw data, inline or external file, freefield format (blank or comma delimited)
	write outfile="[fn]"
	By default, both commas and blanks are interpreted as delimiters on input.

	input program - data list - repeating data - end input program or file type - repeating data - end file type
	raw data, input cases with records containing repeating groups of data
	
	

	file type - record type - data list - end file type
	raw data, mixed, hierarchical, nested files, grouped files
	
	

	matrix data
	raw matrix data, including vectors
	
	

	file handle [nickname] name="[fn]" followed by get file "nickname"
	record length >8,192, EBCDIC data files, binary data files, character data files not delimited by ASCII line feeds
	file handle [nickname] name="[fn]" followed by write outfile="[nickname]
	

	get sas data="[fn]"
	SAS dataset  version 9
	save translate / outfile="[fn]" / type=sas / version=9
	

	get sas data="[fn].sd2" (or Unix: [fn].ssd[nn])
	SAS dataset version 6
	save translate / outfile="[fn]" / type=sas / version=6
	

	get sas data="[fn].sd2" (or Unix: [fn].ssd[nn])
	SAS dataset version 7 with file of value labels 
	save translate / outfile="[fn]" / type=sas / version=7 / valfile="[fn]"

	get sas data="[fn].sas7bdat"
	SAS dataset version 7 with file of value labels 
	save translate / outfile="[fn]" / type=sas / version=7 / valfile="[fn]"

	get sas data="[fn].dat"
	SAS transport file
	save translate / outfile="[fn]" / type=sas / version=X
	

	get data / type=txt / file="[fn]"
	similar to DATA LIST, does not create temporary file
	save translate / outfile="[fn]" / type=csv
	

	get file="[fn].sys"
	SPSS /PC+
	save translate / outfile="[fn].sys" / type=pc
	

	import file="[fn].por"
	SPSS portable 
	export outfile="[fn].por"
	

	get file="[fn].sav"
	SPSS system file
	save outfile="[fn]" or xsave outfile="[fn]"
	

	get stata file="[fn].dta"
	Stata-format data files version 6
	save translate / outfile="[fn]" / type=stata / version=6
	

	get stata file="[fn].dta"
	Stata-format data files version 7
	save translate / outfile="[fn]" / type=stata / version=7
	

	get stata file="[fn].dta"
	Stata-format data files version 8
	save translate / outfile="[fn]" / type=stata / version=8
	

	get stata file="[fn].dta"
	Stata-format data files versions 4-5
	save translate / outfile="[fn]" / type=stata / version=5
	

	get translate / type=wk / file="[fn]"
	Symphony file, any
	
	

	get translate / type=wrk / file="[fn]"
	Symphony release 1.0
	save translate / outfile="[fn]" / type=sym / version=1
	

	get translate / type=wr1 / file="[fn]"
	Symphony release 2.0
	save translate / outfile="[fn]" / type=sym / version=2
	

	get translate / type=sys / file="[fn]"
	Systat data file
	
	

	get translate / type=tab / file="[fn]"
	tab-delimited ASCII file
	save translate / outfile="[fn]" / type=tab
	Embedded tabs are interpreted as delimiters

	get capture
	
	
	Obsolete, use get data


Data: ist_corrected_uk1.csv





Syntax: ist_labels1.sps





SPSS





SPSS system file





RUN icon








� Unless otherwise specified, all following Menu > [Submenu] > Item references are to drop-down menus in the SPSS interface.


� To enable the display of the number of lines and line length in Notepad (as opposed to Notepad++), turn off Format > Word Wrap and click on the last line of the file. The line number of the last line will be displayed at the bottom of the screen.





� Exploratory Data Analysis








